
9.1 

Using Spreadsheets 
with the Internet 
After completing this lesson, you will be able to: 

� Create and edit hyperlinks in worksheets. 

� Save worksheets and workbooks as Web pages. 

� Send workbooks via e-mail.  

� Add comments to workbook cells. 

� View and edit comments. 

With Microsoft Excel, it’s easy to share your data with others using the 

Internet. You can send Excel workbooks via e-mail. You can also save Excel 

files as Web pages to be viewed in a Web browser, even by people who don’t 

have Excel. And you can enhance your worksheet using hyperlinks to refer to 

related files or Web pages. Finally, you and your colleagues can also enhance 

workbook data by adding comments that offer insight into why sales were so 

good on a particular day or whether a product might be discontinued. 

In this lesson, you learn how to use Excel with the Internet. You insert and 

modify hyperlinks in a worksheet, save a workbook as a Web page, and send a 

workbook via e-mail. In this lesson, you’ll also learn how to manage comments 

to workbook cells. 

At Adventure Works, the human resources department is gathering information 

to post on the company intranet. The administrative assistant is compiling a list 

of useful online resources and creating a table of the company’s holiday 

schedule in Excel. 

To complete the procedures in this lesson, you will need to use the file 

Intranet.xls in the Lesson09 folder in the Spreadsheet Fundamentals Practice 

folder located on your hard disk. 

Creating and Editing Hyperlinks 

A hyperlink is an image or a sequence of characters that opens another file or 

Web page when you click it. The target file or Web page can be on the World 

Wide Web, on an intranet, or on your own computer. The text of a hyperlink 

typically appears underlined and in a different color than the text around it. 

Excel makes it easy for you to embed hyperlinks in worksheet cells. Each 

hyperlink appears as blue underlined text in the cell. If you point to a hyperlink, 

a ScreenTip describing the link or giving the location of the file appears. 

Many of the staff members at Adventure Works use Microsoft Office in their 

everyday work, so the administrative assistant wants to add a link to the 

Microsoft Office Web site to her list of online resources. 

LESSON 9 



9.2  Spreadsheet Fundamentals 

important 

You must have access to the Internet in order to complete this exercise. If 

you need to establish this connection manually, you should do so before 

beginning the exercise. 

In this exercise, you create a hyperlink in a worksheet, edit the hyperlink, and 

test and remove the hyperlink. 

1 Open the Intranet workbook from the Lesson09 folder in the 

Spreadsheet Fundamentals Practice folder. 

2 Click cell A4. 

3 On the Standard toolbar, click the Insert Hyperlink button. 

The Insert Hyperlink dialog box appears. 

 

4 In the Text to display box, type Microsoft. 

5 In the Address box, type www.microsoft.com, and click OK. 

The hyperlink appears in cell A4. 

 

6 Point to the cell with the hyperlink. 

The default ScreenTip appears which lists the full address of the 

hyperlink and provides instructions for following the hyperlink or 

selecting the cell. 

7 Click the hyperlink. 

Your Web browser opens and connects to the Microsoft Web site. 

8 On the taskbar, click the Excel button to return to your workbook. 

Right-click cell A4 and click Edit Hyperlink. 

9 In the Text to display box, click to the right of the word Microsoft, 

press the spacebar, and then type Office. 

To insert a hyperlink without 

using the toolbar button, click 

the cell you want to contain 

the link, and press Ctrl+K on 

your keyboard. 

Because you are typing an 

Internet address, http:// is 

automatically added to the 

address for you. 

You can also edit hyperlink 

text directly using the 

Formula bar. Select the cell 

containing the hyperlink using 

one of the following methods: 

(1) click an adjacent cell and 

use the arrow keys to select 

the cell, (2) click on the cell 

and hold the mouse button 

down until the cell is 

selected, or (3) hold down the 

Ctrl key while you click on the 

cell. Then click in the 

Formula bar to edit the 

hyperlink text. 
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10 In the Address box, click to the right of www.microsoft.com, and 

type /office. 

11 Click the ScreenTip button. 

The Set Hyperlink ScreenTip dialog box appears. 

12 Click in the ScreenTip text box, type Microsoft Office Home Page, 

and then click OK. 

The Set Hyperlink ScreenTip dialog box closes. When you point to 

the hyperlink, a ScreenTip with the words Microsoft Office Home 

Page will appear. 

13 In the Edit Hyperlink dialog box, click OK. 

The updated hyperlink appears in cell A4. 

14 Point to the hyperlink. 

The edited ScreenTip appears. 

15 Click the hyperlink. 

Your Web browser opens and connects to the Microsoft Office site. 

16 Close both instances of your browser, and return to the worksheet. 

17 Right-click the hyperlink and click Remove Hyperlink. 

The text remains in cell A4, but the hyperlink is removed. 

18 Save the workbook. 

Keep this file open for the next exercise. 

Using Web Page Preview 

Before you save a worksheet or workbook as a Web page, you can use Web 

Page Preview to view the page as it will appear when it is viewed in a browser. 

To preview a worksheet as a Web page, on the File menu, click Web Page 

Preview. The worksheet opens as a Web page in your default browser. 

Saving Worksheets and Workbooks as 
Web Pages 

By saving a worksheet or workbook as a Web page, you can quickly create a 

file that can be viewed in a Web browser without using Excel. When you save a 

file as a Web page, Excel uses Hypertext Markup Language (HTML) to 

format the data for display in a Web browser. 

At Adventure Works, the administrative assistant is ready to create Web pages 

from the links and holidays worksheets she created. 

You might not have to type 

the backslash in the URL. If 

there is already a backslash 

after www.microsoft.com, you 

do not need to type a second 

backslash. 

This dialog box allows you to 

type the text you want to 

appear when the mouse 

pointer is hovered over the 

hyperlink. 

Before you save a worksheet 

as a Web page, make sure to 

save the file to a disk. 
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In this exercise, you save a worksheet and a workbook as a Web page. 

1 On the File menu, click Save As. 

The Save As dialog box appears. 

2 Click the Save as type down arrow, and click Web Page. 

The Save As dialog box changes to offer options specific to saving 

in Web page format. 

 

3 Click the Selection: Sheet option. 

4 In the File name box, select the current text, type Links.htm, and 

then click Save. 

Excel saves the worksheet as a file in HTML format. 

5 On the File menu, click Save As. 

The Save As dialog box appears. 

6 Click the Save as type down arrow, and click Web Page. 

7 Click the Entire Workbook option, if necessary, and click Save. 

Excel saves the entire workbook (with the name Intranet) as a file in 

HTML format. A folder is also created with the same name as the 

file. This folder contains any associated files that are needed to 

produce the Web page. 

8 Close the workbook. 

9 Open Windows Explorer, navigate to the Lesson09 folder in the 

Spreadsheet Fundamentals Practice folder, and then double-click 

the file Links.htm to open it. 

The Links worksheet appears in your Web browser, as shown in 

the illustration on the following page. 

If you open the Links.htm file 

in Excel, it will not start your 

Web browser. It will simply 

appear in an Excel 

worksheet. 
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10 From Windows Explorer, open the file Intranet.htm. 

The Intranet workbook appears in your Web browser, with the Links 

worksheet in front. 

11 At the bottom of the page, click the Holidays link. 

The Holidays worksheet appears. 

 

12 Close both Web browser windows. 

tip 

By default, others will be able to view, but not edit, the worksheets you save 

as Web pages. To allow others to edit these worksheets, use the Add 

Interactivity option in the Save As dialog box. 
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Sending Workbooks via E-mail 

With Excel, you have two options for sending a workbook via e-mail. You can 

send a worksheet or workbook in the body of an e-mail message without 

leaving Excel, or you can send an Excel file as an attachment to an e-mail 

message. 

At Adventure Works, the administrative assistant wants to send the contents of 

the Intranet workbook to the human resources manager for approval before 

posting them to the intranet. 

important 

You must have access to the Internet in order to complete this exercise. If 

you need to establish this connection manually, you should do so before 

beginning the exercise. 

In this exercise, you mail the worksheet to yourself and then open the file from 

your e-mail program. 

1 Open the Intranet workbook. 

2 On the File menu, point to Send To, and click Mail Recipient. If the 

Office Assistant appears, asking if you want to send the workbook 

as an attachment or as the message body, click the Send the 

current sheet as the message body option. 

The e-mail header form appears. 

 

3 In the To box, type your e-mail address, and click the Send this 

Sheet button. 

Excel sends the message and closes the e-mail header. 

4 Start your e-mail program, and check for new messages. 

You can also click the E-Mail 

button on the Standard 

toolbar, which will give you 

the option of sending the 

workbook as an attachment 

or sending the workbook as 

the message body. 

If your e-mail program is set 

up to store messages to send 

later, Excel displays a 

message box to remind you. 
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5 Open the message you sent. 

The Excel worksheet appears in the body of your message. 

 

6 Close the message, and return to the worksheet. 

7 On the File menu, point to Send To, and click Mail Recipient (As 

Attachment). 

An e-mail message form appears, with the Excel file included as an 

attachment to the message. 

 

8 In the To box, type your e-mail address, and click Send. 

9 Close the workbook. 

10 Switch to your e-mail program, and check for new messages. 

11 Open the message you sent, and double-click the attachment. 

The workbook opens in Excel. 

12 Close the e-mail message but leave the workbook open for the next 

exercise. 
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Managing Comments 

Excel makes it easy for you and your colleagues to add comments to workbook 

cells, thus adding insights that go beyond the cell data. For example, if rental 

equipment sales were exceptionally high for a particular day, the manager on 

duty could add a comment to the cell in which she records the sales for that 

day, noting that two exceptionally large groups visiting the resort accounted for 

the disparity. 

When you add a comment to a cell, a flag appears in the upper-right corner of 

the cell. When the mouse pointer hovers over a cell with a comment, the 

comment appears in a box next to the cell, along with the name of the user 

logged on to the computer at the time of the comment. 

tip  

The name attributed to a comment may not be the same as the person who 

actually created it. Enforcing access controls, such as requiring users to 

enter account names and passwords when they access a computer, can 

help track who made a comment or change. 

You can add a comment to a cell by clicking the cell and clicking Comment on 

the Insert menu. When you do, the comment flag appears in the cell and a 

comment box appears next to the cell. You can type the comment in the box 

and, when you’re done, click another cell to close the box for editing. When 

you move the mouse pointer over the cell with the comment, the comment will 

appear next to the cell. 

If you want the comment to be shown the entire time the workbook is open, 

right-click the cell with the comment and then click Show Comment from the 

shortcut menu that appears. You can hide the comment by clicking Hide 

Comment from the same menu, delete the comment by clicking Delete 

Comment, or open the comment for editing by clicking Edit Comment. 

The tools to insert, edit, 

delete, or move between 

existing comments as well as 

to show or hide them are all 

avaliable on the Reviewing 

toolbar. To open the 

Reviewing toolbar, point to 

Toolbars on the View menu 

and click Reviewing or right-

click in the toolbar area and 

click on Reviewing in the 

pop-up list. 
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In this exercise, you add a comment to a cell. You then review and delete the 

comment. 

1 In the Intranet workbook, switch to the Holidays worksheet and click 

cell B6. 

2 On the Insert menu, click Comment. 

A comment field appears. 

 

3 In the comment field, type This date was added to provide a long 

weekend. and then click cell B7. 

A red comment flag appears in the upper-right corner of cell B6. 

4 Move the mouse pointer over cell B6. 

The comment in cell B6 appears. 

5 Right-click cell B6, and then, from the shortcut menu that appears, 

click Edit Comment. 

The cursor is placed at the end of the existing comment. 

6 Double-click the word was in the comment to select it and then type 

and the following Monday were. 

The existing comment is edited to include the new phrase. 

7 Right-click cell B6 and then, from the shortcut menu that appears, 

click Delete Comment. 

The comment is deleted from cell B6. 

When someone other than 

the original user edits a 

comment, that person’s input 

is marked with the new user’s 

name and is added to the 

original comment. 



9.10  Spreadsheet Fundamentals 

Lesson Wrap-Up 

In this lesson, you learned how to create and edit hyperlinks in a worksheet, 

save worksheets and workbooks as Web pages, and send workbook information 

using e-mail. You also learned how to add and edit comments to cells within a 

worksheet. 

If you are continuing to other lessons: 

■ Save and close all open workbooks. 

If you are not continuing to other lessons: 

1 Save and close all open workbooks. 

2 Click the Close button in the top-right corner of the Excel window. 

Quick Quiz 

1 What are two ways to insert a hyperlink in a selected worksheet 

cell? 

2 How can you send a workbook via e-mail? 

3 How can you save a workbook or worksheet as a Web page? 

4 How can you edit the text of a hyperlink without using the shortcut 

menu? 

5 How can you edit a hyperlink in a worksheet cell? 

Putting It All Together 

Exercise 1: Open the Intranet workbook. On the Links worksheet, create a 

hyperlink to a file on your hard disk. Edit the text of the hyperlink, and add a 

descriptive ScreenTip. Preview the workbook as a Web page, and save the 

Links worksheet as a Web page. Close the workbook, and open the Links Web 

page in your Web browser. 

important 

In order to complete the Putting It All Together Exercise 2, you must have 

access to the Internet. If you need to establish this connection manually, 

you should do so before beginning the exercise. 

Exercise 2: Open the Intranet workbook, and remove the hyperlink you added 

to the Links worksheet. Send the workbook to one of your class partners in the 

body of an e-mail message. 
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Exercise 3: Open the Reviewing toolbar. Use the Insert Comment button to 

insert a new comment into cell B11. Type Should we add another day here to 

provide a long weekend?. Click in cell B6 and insert a comment. Type I’d 

rather not have this day off and get off another day at Christmas time. Use 

the Reviewing toolbar and move to the next comment.  

Exercise 4: In this lesson we created a hyperlink to a Web site. Is it possible 

to create a hyperlink to another spot within the worksheet or to another 

worksheet on your hard drive? Explore the Insert Hyperlink dialog box or use 

Excel’s Help files to find the answer to this question. 

Exercise 5: If you have visited a Web site recently, is there a quick way to 

establish a hyperlink to this page without having to type in all of the text to get 

to the specific page to which you want to link? Explore the Insert Hyperlink 

dialog box or use Excel’s Help files to find the answer to this question. 


