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� Use FrontPage to automate Web page creation. 

� Design subpages from a standard template, insert tables, and add navi-

gation buttons and page footers. 

� Define Cascading Style Sheets (CSS) to format Web pages. 

� Create image maps and forms to make your site more interactive. 

� Use FrontPage to create a home page. 

When you watch the news on TV, the only “equipment” you need is the TV and 

a place to sit. But what about when you rent a video or order a pay-per-view 

movie that’s filled with cool special effects and has an awesome soundtrack? 

Instead of turning to grandma’s 13-inch hand-me-down TV, you’d probably pre-

fer the ultimate in home entertainment systems: You know, the rare setup that 

can be easily controlled by a single remote control and has an ultra-clear big-

screen TV, digital cable, Dolby stereo, and surround sound components artfully 

blending into the shadows—all strategically placed for optimal viewing and lis-

tening pleasure from the comfortable folds of an enormous leather couch. 

Granted, these “extras” aren’t strictly necessary, but they sure can make a big 

difference sometimes. The same can be said of HTML editors. Notepad (a basic 

text editor) can be likened to the “TV, seat, and remote control” way of creating 

Web pages, whereas FrontPage provides the “luxury home entertainment sys-

tem” approach to Web site development. In this lesson, we’re going for the “ex-

tras.” 

To create the Web pages described in this lesson, you’ll need the following 

“supplies”: 

■ A copy of Microsoft FrontPage (preferably version 2002). 

■ 38 practice files, all of which can be found in the Lesson07 folder 

under the Web Design Fundamentals Practice folder on your hard 

drive. These files include mars.doc, thankyou.htm, and 36 graphics 

files that you will use in the Web site you create using FrontPage. 

To get set up for the activities in this lesson, follow these steps: 

1  Create a folder named “sky” on your computer’s hard drive. (For 

convenience, we refer to your hard drive as the C:\ drive through-

out this lesson.) 

2 Copy the mars.doc and thankyou.htm files in the Lesson07 folder 

found under the Web Design Fundamentals Practice folder to the 

C:\sky folder you just created. 
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3 Create an images folder in C:\sky and copy the following graphics 

files (found in the Lesson07 folder under the Web Design Funda-

mentals Practice folder on your hard drive).to that folder: 

 

b_aboutus.gif bg.gif mars.jpg 

b_aboutus2.gif bigdip1.gif neptune.jpg 

b_contact.gif bigdip2.gif saturn.jpg 

b_contact2.gif bigdip3.gif solarsystem.gif 

b_gallery.gif bigdip4.gif t_aboutus.gif 

b_gallery2.gif bigdip5.gif t_contact.gif 

b_links.gif bullet_star.gif t_gallery.gif 

b_links2.gif corner_botm_left.gif t_links.gif 

b_meetings.gif corner_botm_right.gif t_meetings.gif 

b_meetings2.gif corner_top_left.gif t_skyguide.gif 

b_skyguide.gif corner_top_right.gif titlebar-home.gif 

b_skyguide2.gif logo.gif titlebar.gif 
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When we initially planned this lesson’s project site, we intended to create a team 

page featuring a fictitious softball team. Unfortunately, we couldn’t bribe enough 

of our friends to pose for the team picture, so we opted to create a Web site for 

an astronomy club instead. We ended up incorporating many of the functionali-

ties we had originally planned for the softball site into the astronomy site. For 

example, instead of making an image map out of a team picture, in which you 

could click each person’s head to access a stats or personal page, we used a solar 

system image map in which you can click each planet to access a page of infor-

mation about that planet. We hope that as you experiment with the techniques we 

present in this project, you’ll begin to think of ways you can vary them to create 

custom Web sites. 

After determining that an astronomy club site would suit our purposes, we de-

cided that the site should consist of a custom home page linking to standard-

format subpages. Using a nonstandard home page is a common Web site design 

technique used to make the home page stand out from the subpages. Because 

FrontPage offers so many options, we felt that showing a nonstandard home page 

made good design sense and would also enable us to show you a few additional 

features of FrontPage. To see our planning process, take a look at Figures 7-3 

through 7-5. Figure 7-3 shows a sketch of the Big Dipper design we came up 

with for the home page. Figure 7-4 shows the sketch of the standard subpage 

layout. And finally, Figure 7-5 shows the astronomy club site’s storyboard. 
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Figure 7-3. 

A sketch of the astronomy club’s home page shows the big dipper containing 

links to the site’s main subpages. 
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Figure 7-4. 

A sketch of a typical astronomy club subpage shows that the subpages will be 

structured differently from the home page. 
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Figure 7-5. 

Storyboarding the astronomy club’s Web site clarifies the Web site’s hie-

rarchy. 

Because of the relative complexity of the home page, you’re going to create that 

page last. In this project, you’ll start the design process by solidifying the site’s 

standard layout for subpages by creating a subpage.htm document that you can 

use as a template to create the site’s pages. But first, before you begin building 

Web pages, you need to tell FrontPage that you want to create a new Web. 
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As we just mentioned, the first step to designing a Web site is to express your 

Web-page-building intentions to FrontPage by creating a new Web. To do so, 

follow these steps: 
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1 Ensure that you’ve created a folder named C:\sky\images in which 

you’ve placed the images you copied from the Lesson07 folder 

found under the Web Design Fundamentals Practice folder on your 

hard drive. Also be sure that you’ve copied mars.doc and than-

kyou.htm from the Lesson07 folder and stored the files in C:\sky. 

2 Open FrontPage, and close the blank document if a blank docu-

ment displays. 

3 If the Page Or Web task pane isn’t displaying, open the File menu, 

select New and then click Page Or Web. 

4 In the New section, click the Empty Web option and the Web Site 

Templates dialog box opens. Click in the Specify The Location Of 

The New Web text box, highlight the existing text, type C:\sky or 

click Browse and navigate to C:\sky, and then click OK. After some 

brief processing in which FrontPage adds FrontPage Server Exten-

sions to your Web folder (C:\sky), you’ll see the FrontPage title bar 

change to Microsoft FrontPage -C:\sky, which means you’re ready 

for action. 

5 In the Views bar along the left side of the FrontPage window, click 

the Reports icon. A site summary appears. This report displays be-

cause you have graphics stored in C:\sky\images and mars.doc 

and thankyou.htm stored in C:\sky. 

Note Although having all the images you plan to use on your Web site ready up 

front is convenient, it’s not necessary. But because the astronomy club’s graph-

ics are readily available (and because this course is about creating Web pages, 

not Web graphics), you can simplify creating the Web in this project (or any 

project for that matter) by organizing the graphics for the site before you start 

creating it. 

6 Click the Page icon in the Views bar and click Create A New Nor-

mal Page button in the Standard toolbar to open a blank page (no-

tice the title bar text in FrontPage changes to Microsoft FrontPage 

-C:\sky\new_page_1.htm). 

You’re now ready to create a standard subpage that you can use as a template 

for the astronomy club’s Web site. 
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In this section you’ll create a standard subpage layout that you’ll be able to copy 

and use to create foundation pages for each subpage in the site. First you’ll set 

the subpage’s page properties. 
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To begin, ensure that you have a blank workspace displaying in FrontPage. If 

you followed the steps in the preceding section, you should be set. Here are the 

steps to create a basic subpage: 

FrontPage refers to Web sites 

as Webs. 
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1 Right-click a blank area on the page and select Page Properties. 

The Page Properties dialog box opens. 

2 In the Title text box on the General tab, type The Astronomy 

Club, as shown in Figure 7-6. 

 
Figure 7-6. 

You can enter title text in the Page Properties dialog box. 

3 Click the Background tab, select the Background Picture check box 

to specify that you want the page to use a background picture, and 

then click Browse. 

4 In the Select Background Picture dialog box, double-click the im-

ages folder in C:\sky and then click bg.gif, as shown in Figure 7-7. 

5 Click Open to select the background image and return to the Page 

Properties dialog box. 

To see a thumbnail of a se-

lected image in the Select 

Background Picture dialog 

box, click the Views drop-down 

arrow in the dialog box’s tool-

bar and select Preview. 
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Figure 7-7. 

To assign a background image to your Web page, select bg.gif in the Select 

Background Picture dialog box. 

6 Continuing on the Background tab, click the Enable Hyperlink Rol-

lover Effects check box, and then click the Rollover Style button. 

The Font dialog box opens. In the Font area, retain the (Default 

Font) selection, and in the Font Style text box, select Normal. 

7 Click the Color drop-down box, click the red color square (red’s the 

default color), and click OK. This setting specifies to display text 

links in red whenever a user’s mouse cursor hovers over the text 

link. 

8 Next on the Background tab, click the Background drop-down ar-

row and click the black color box; then click the Text drop-down ar-

row and click the black color box. 
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Step 8 doesn’t contain a mistake—you should set both the background and the 

text colors to black. For this project, most of the text you enter will display in 

white table cells, so to save yourself time later on, you should set the default text 

color to black at this point even though the background is set to black as well. 

9 Click the Hyperlink drop-down arrow and click the blue color box; 

click the Visited Hyperlink drop-down arrow and click the purple 

color box; then click the Active Hyperlink drop-down arrow and 

click the red color box. The Background tab should now look like 

the one shown in Figure 7-8. 

Lingo: An active hyperlink 

refers to a hyperlink that’s 

being clicked. If you set an 

active hyperlink color property 

to red, the hyperlink will appear 

red while the user clicks the 

link. 
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Figure 7-8. 

The completed Background tab shows the default colors you selected for 

the current Web page. 

Even though the project uses the default hyperlink colors, you 

should click each component’s color boxes to replace the “auto-

matic” color setting for each element. If you don’t replace the au-

tomatic colors with specified colors, some browsers might insert 

custom hyperlink colors that might not work well with your site—for 

example, if a user’s “visiting” hyperlinks are set to black, the links 

will disappear into the black background after the user clicks them. 

10 Click OK to implement the Page Property settings and close the 

Page Properties dialog box. 
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Before you get too far along, you should save your work. You’ll be able to use 

the same basic settings for all subpages, so you’ll save the page you’re currently 

creating as a generic template that you can copy to create all the site’s subpages. 

To save the current file, follow these steps: 

1 On the File menu, click Save. 

2 In the Save As dialog box, click the Change Title button (located in 

the lower-right portion of the dialog box) to open the Set Page Title 

dialog box, and change the text to The Astronomy Club: Generic 

Page, as shown in Figure 7-9. Then click OK. 
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Figure 7-9. 

You configure the Set Page Title dialog box to modify a page’s title text. 

3 In the File Name text box, type subpage, and then click Save. 
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In this section you’ll continue to configure the subpage template by inserting the 

astronomy club’s logo and title banner graphic, which appears along the top of 

every page: 

1 In the C:\sky\subpage.htm document (which should be opened in 

FrontPage if you’re continuing the project from the previous sec-

tion), click the Insert menu, point to Picture, and then choose From 

File. 
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If you closed subpage.htm, you can reopen the document by opening 

FrontPage, clicking the Open icon (or clicking Open on the File menu), na-

vigating to C:\sky in the Open dialog box, and double-clicking sub-

page.htm. 

2 In the Picture dialog box, display the contents of the images folder 

in the C:\sky\images folder, select the logo.gif file, and click Insert 

(or, simply double-click the logo.gif file). The logo (which is Saturn 

and a few miscellaneous moons) displays on the page. 

3 On the Standard toolbar, click the Insert Picture From File button, 

and double-click the titlebar.gif file. The title bar image is inserted 

next to the logo. 

4 Right-click the logo.gif image (the Saturn image), select Picture 

Properties, click the General tab, click in the Text box in the Alter-

native Representations section, type Astronomy Club Logo, and 

then click OK. 

5 Right-click the titlebar.gif image, select Picture Properties, click the 

General tab, click in the Text box in the Alternative Representa-

tions section, type Astronomy Club, and then click OK. 
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6 Right-click the logo image again, select Hyperlink, type index.htm 

in the Address text box, and then click OK. 

At this point, the logo is linked to the (future) home page, and both graphics are 

inserted and left-aligned by default. In most browsers, the left alignment will 

help keep the graphics side by side, but because two images span the top of your 

page, the title bar could feasibly wrap to the next line in some browsers if users 

resized their browser windows to a very small size (in which case the logo would 

display on the top line and the title bar would display flush-left below the logo 

graphic on the next line—not the effect you’re after for this Web site). Just to be 

safe, you can add the “no break” (<NOBR></NOBR>) HTML tags to your 

page’s source code to specify that the two graphics should be kept together re-

gardless of the browser’s window size. 

7 In FrontPage, click the HTML view option. The HTML source code 

displays in FrontPage’s workspace window. 

Before you add the <NOBR></NOBR> tags, let’s make working in Front-

Page easier by enabling FrontPage to wrap the code text. 

8 Click Tools, click Page Options, and display the HTML Source tab. 

9 In the General section, click Reformat Using the Rules Below, se-

lect the Allow Line Breaks Within Tags check box in the Formatting 

section, and click OK. 

Now you’ll be able to view your HTML code without having to scroll 

left and right as much, which means you’re ready to add the 

<NOBR></NOBR> tags. 

10 In the source code, click after the opening paragraph tag (<p>), 

type <NOBR>, click before the closing paragraph tag (</p>), and 

type <NOBR>. Figure 7-10 shows the newly added HTML tags (in 

orange) that will ensure that the graphics will always display next to 

each other. 
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Figure 7-10. 

Adding <NOBR> and </NOBR> to a page’s source code ensures that 

a line break won’t separate particular elements. 

11 Click Save (your capped code will automatically change to all lo-

wercase code), and then click the Normal view tab to redisplay the 

graphical representation of subpage.htm in your working area. Your 

page should display as shown in Figure 7-11. 
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Figure 7-11. 

At this point the subpage.htm includes background, logo, and title bar 

images. 
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In this section you’ll create the foundation table used to contain the body text of 

each subpage in the astronomy club’s Web site. Take your time going through 

the upcoming steps—it’s easier to configure your table correctly the first time 

around instead of trying to find an erroneous setting. Furthermore, although this 

section might seem to include a few too many steps, the steps throughout are 

fairly repetitious, so the process isn’t overly complex. (In other words, don’t let 

the number of steps get to you.) When you create your own tables, you’ll proba-

bly have to experiment with a few settings before you get your table just right—

which is exactly what we do, too. To create your table for this project, follow 

these steps: 

1 Press your down arrow key once to position your cursor below the 

graphics, and press Shift+Enter to position your cursor where you 

want to insert the table. 

2 In the Standard toolbar, click the Table button, drag to select two 

rows and five columns worth of boxes on the pop-up window, and 

then release to insert the table into your page. Figure 7-12 illu-

strates the table creation process. As you can see, the table bor-

ders display when you first insert a table. In effect, the table’s 

borders are set to display as 1-pixel wide. Later, after you fill the 

table with content, you’ll change the table’s borders setting to 0 to 

hide the table’s lines. 
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Figure 7-12. 

By default, FrontPage creates tables with a 1-pixel border. 

3 Right-click anywhere on the table, choose Table Properties, ensure 

that Cell Padding is set to 0, Cell Spacing is set to 0, Specify Width 

is set to 100 percent, the Size setting under Borders is set to 1, and 

click OK. 

4 Right-click the cell in row 1, column 1. On the shortcut menu, se-

lect Cell Properties. 

5 In the Cell Properties dialog box, set the Horizontal Alignment op-

tion to Center, set Vertical Alignment to Top, ensure that the Speci-

fy Width check box is selected, enter 130 in the Specify Width text 

box, and select the In Pixels option, as shown in Figure 7-13. 



Lesson 7 Creating Web Sites with FrontPage 7.15 

 
Figure 7-13. 

You use the Cell Properties dialog box to configure a table cell. 

6 Click OK to activate the settings. 

7 Right-click the cell in row 2, column 1. On the shortcut menu, se-

lect Cell Properties. 

8 In the Cell Properties dialog box, set the Horizontal Alignment Op-

tion to Center, set Vertical Alignment to Bottom, set the Specify 

Width setting to 130 pixels, select the Specify Height check box, 

set the Specify Height setting to 15 pixels, and click OK. 

9 Right-click the cell in row 1, column 2. Select Cell Properties. Set 

the Horizontal Alignment Option to Left, set Vertical Alignment to 

Top, set the Specify Width setting to 1 pixel, and click OK (don’t 

worry if you don’t see a change in your table just yet—the cell won’t 

resize until you format the cell below it as well). 

10 Right-click the cell in row 2, column 2. Select Cell Properties. Set 

the Horizontal Alignment Option to Left, set Vertical Alignment to 

Bottom, set the Specify Width setting to 1 pixel, select the Specify 

Height check box, set the Specify Height setting to 15 pixels, and 

click OK. (Now the second column in your table should be 1-pixel 

wide.) 

11 Right-click the cell in row 1, column 3. On the shortcut menu, se-

lect Cell Properties, set Horizontal Alignment to Left, set Vertical 

Don’t forget to save often while 

you work! 
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Alignment to Top, set the Specify Width setting to 15 pixels, speci-

fy the Background Color as White, and click OK. 

12 Right-click the cell in row 2, column 3. On the shortcut menu, se-

lect Cell Properties, set Horizontal Alignment to Left, set Vertical 

Alignment to Bottom, set the Specify Width setting to 15 pixels, 

click the Specify Height check box, set the Specify Height setting 

to 15 pixels, specify the Background Color as White, and click OK. 

13 Right-click the cell in row 1, column 4. On the shortcut menu, se-

lect Cell Properties, set Horizontal Alignment to Left, set Vertical 

Alignment to Top, clear the Specify Width check box (don’t set a 

width for this column because you’ll want it to resize to fit each us-

er’s browser window), specify the Background Color as White, and 

click OK. 

14 Right-click the cell in row 2, column 4. On the shortcut menu, se-

lect Cell Properties, set Horizontal Alignment to Left, set Vertical 

Alignment to Bottom, clear the Specify Width check box, select the 

Specify Height check box, set the Specify Height settings to 15 

pixels, specify the Background Color as White, and click OK. 

15 Right-click the cell in row 1, column 5. On the shortcut menu, se-

lect Cell Properties, set Horizontal Alignment to Right, set Vertical 

Alignment to Top, set the Specify Width setting to 15 pixels, speci-

fy the Background Color as White, and click OK. 

16 Right-click the cell in row 2, column 5. On the shortcut menu, se-

lect Cell Properties, set Horizontal Alignment to Right, set Vertical 

Alignment to Bottom, set the Specify Width setting to 15 pixels, set 

the Specify Height setting to 15 pixels, specify the Background 

Color as White, and click OK. Your table should now display as 

shown in Figure 7-14. 
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Figure 7-14. 

You can modify the internal layout of a table by adjusting cell properties. 

Notice in Figure 7-14 that the right set of table cells displays as a 

white rectangular area. You’re now going to add small graphics to 

the white area’s corner cells to create the illusion that the table has 

rounded corners: 

17 Click in the cell in row 1, column 3. On the Insert menu, point to 

Picture and choose From File. Select the corner_top_left.gif image 

in the C:\sky\images folder, and then click OK. 
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To get an idea of how the corner graphics work, view the small curved 

graphics in a paint program or preview the image in the Insert Picture di-

alog box. You can easily imagine how the small curve can create the illu-

sion of a rounded corner when it’s inserted into a table cell. 

18 Click in the cell in row 2, column 3. Click Insert Picture From File 

on the Standard toolbar, and double-click corner_botm_left.gif im-

age in the C:\sky\images folder. 

19 Right-click the newly inserted corner_botm_left.gif image. On the 

shortcut menu, click Picture Properties, click the Appearance tab if 

necessary, select Bottom in the Alignment drop-down list, and click 

OK. 

20 Click in the cell in row 1, column 5 (because you formatted the cell 

to align information to the right, your cursor will appear to the far 

right of the cell). Click Insert Picture From File on the Standard 
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toolbar, and double-click corner_top_right.gif image in the 

C:\sky\images folder. 

21 Click in the cell in row 2, column 5. Click Insert Picture From File, 

and double-click corner_botm_right.gif image in the C:\sky\images 

folder. 

22 Right-click the newly inserted corner_botm_right.gif image. On the 

shortcut menu, click Picture Properties, click the Appearance tab if 

necessary, select Bottom in the Alignment drop-down list, and click 

OK. 

23 Click Save on the toolbar. At this point, your table should display 

as shown in Figure 7-15. 

 
Figure 7-15. 

Small graphics added to table cells create the appearance of rounded ta-

ble corners. 
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Now that the table is created, you’re ready to start filling the table’s cells. First 

on the agenda is to add some navigation buttons to the first column in the table. 

FrontPage offers some nice special-effects buttons, which you’ll use in this 

project: 

1 Click in the cell in row 1, column 1. 

2 On the Insert menu, point to Web Component, select Dynamic Ef-

fects in the Component Type section, choose Hover Button in the 

Choose An Effect section (notice the component’s description dis-

plays below the list boxes in the Insert Web Component dialog box; 

as you click effects, the description changes), and click Finish. 
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3 Configure the Hover Button Properties dialog box, as shown in 

Figure 7-16, using the following settings: 

Option Setting 

Button Text Home 

Link To index.htm 

Button Color Navy 

Effect Glow 

Width 120 

Background Color Automatic 

Effect Color Blue 

Height 24 

 
Figure 7-16. 

FrontPage enables you to create hover buttons by configuring the Hover 

Button Properties dialog box. 

4 Click OK. 

5 Press Enter. On the Standard toolbar, click Web Component, en-

sure that Dynamic Effects and Hover Button are selected, and click 

Finish. Type About Us in the Button Text text box, type abou-

tus.htm in the Link To text box, specify the remaining settings as 

outlined in step 3, and then click OK. 

6 Press Enter. Click Web Component, ensure that Dynamic Effects 

and Hover Button are selected, and click Finish. Type Contact Us 

in the Button Text text box, type contact.htm in the Link To text 

box, specify the remaining settings as outlined in step 3 (which are 

the default settings), and then click OK. 
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7 Press Enter. Click Web Component, ensure Dynamic Effects and 

Hover Button are selected, and click Finish. Type Meetings in the 

Button Text text box, type meetings.htm in the Link To text box, 

specify the remaining settings as outlined in step 3, and then click 

OK. 

8 Press Enter. On the Insert menu, click Web Component, ensure 

that Dynamic Effects and Hover Button are selected, and click 

Finish. Type Sky Guide in the Button Text text box, type sky-

guide.htm in the Link To text box, specify the remaining settings 

as outlined in step 3, and then click OK. 

9 Press Enter. Click Web Component, ensure that Dynamic Effects 

and Hover Button are selected, and click Finish. Type Photo Gal-

lery in the Button Text text box, type gallery.htm in the Link To 

text box, specify the remaining settings as outlined in step 3, and 

then click OK. 

10 Press Enter. Click Web Component, ensure that Dynamic Effects 

and Hover Button are selected, and click Finish. Type Astronomy 

Links in the Button Text text box, type links.htm in the Link To 

text box, specify the remaining settings as outlined in step 3, and 

then click OK. 

11 Click Save. Your subpage should display in Normal view and Pre-

view view as shown in Figure 7-17. 

 

Figure 7-17. 

Your table and navigation buttons display in Normal view but not yet in  

Preview view. 

As you can see in Figure 7-17, FrontPage 2002 encounters a little glitch when 

you insert hover buttons; basically, you can’t preview your hover buttons in Pre-

view view automatically (notice the broken link images in the Preview screen 

shown in Figure 7-17). In time, Microsoft might offer a patch to correct this, but 

for now you have two workaround choices: 

■ Preview your pages in your browser by selecting Preview In 

Browser on the File menu, choosing the browser you want to 

use, and clicking Preview. 
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■ Modify each hover button’s code to correct the problem. 

If you choose to preview your Web pages in your browser through-

out the remainder of this exercise, go ahead and skip to the next 

section and choose Preview In Browser on the File menu or click 

the Preview In Browser button on the Standard toolbar each time 

we suggest that you preview your Web page. If you prefer to tweak 

your HTML code a little to avoid opening your browser throughout 

the lesson, we present the steps here. The steps are manageable, 

and this is a prime example of how knowing a little HTML coding 

can help when you’re working with HTML editors. 

12 Click HTML at the bottom of the window to display your page’s 

HTML code. 

The code for each hover button appears between an <applet> </applet> tag 

set, so you should see seven <applet></applet> tag sets in HTML. You can 

tell which button an applet applies to by looking at the value attribute for the 

parameter that defines the button’s text. For example, following is the entire app-

let code for one button; notice that the fifth line indicates that this applet applies 

to the Home button: 

<applet code="fphover.class" codebase="./" width="120" 

height="24"> 

   <param name="color" value="#000080"> 

   <param name="hovercolor" value="#0000FF"> 

   <param name="textcolor" value="#FFFFFF"> 

   <param name="text" value="Home"> 

   <param name="effect" value="glow"> 

   <param name="url" valuetype="ref" value="index.htm"> 

</applet><p> 

The problem in the current hover button code lies in the code-

base="./" attribute in the first line of each <applet> tag. This 

attribute tells FrontPage to look in a subdirectory for the file fphov-

er.class. In actuality, FrontPage stores the class file in the same 

folder as your Web page, so there’s no need for browsers to look in 

a subdirectory for the class file. Although this explanation might 

sound a tad obtuse, the fix is simple—you just need to delete co-

debase="./" in each <applet> tag (see Figure 7-18, where we’ve 

highlighted some of the instances of the codebase="./" attribute), 

as described next. 

13 In the first <applet> tag, select codebase="./" as shown in Figure 

7-18, and press Backspace (or right-click and choose Delete). 
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14 Repeat step 13 for each button’s applet code (remember—you 

have seven buttons, so you should delete codebase="./" seven 

times). 

15 Save your file and click Preview at the bottom of the FrontPage 

window. After you save the code changes, your hover buttons 

should display in Preview mode as expected. 

 
Figure 7-18. 

If you want to preview your hover buttons in FrontPage’s Preview mode, you 

have to slightly tweak each button’s code. 
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If you encounter problems while working in FrontPage (or other Microsoft appli-

cation), a terrific resource to turn to is Microsoft’s online Knowledge Base. To 

access the Knowledge Base, display http:// support.microsoft.com in your 

browser, and click the Search The Knowledge Base link. 
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The final components you’ll add to the subpage template before you begin to 

create actual site pages are the bottom-of-the-page elements: a text-based navi-

gation bar and copyright information. As we discuss earlier in the course, your 

Web pages should include text-based navigation links for users who turn off 

graphics or access the Web with nongraphical browsers. Furthermore, you 

should include copyright information to protect your creation. To add bottom-of-

the-page information to the astronomy club’s Web, follow these steps: 
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1 In Normal view, click in the area below the table, click the drop-

down arrow on the Font Color button in the Formatting toolbar, and 

click the white color box. 

2 Type (including the pipe symbols) Home | About Us | Contact Us 

| Meetings | Sky Guide | Photo Gallery | Links 

3 Select the line of text you just typed, display the font drop-down list 

in the Formatting toolbar, and choose Comic Sans (or Comic Sans 

MS). 

4 Click the Center button on the Formatting toolbar to center the text. 

5 Click at the end of the line of text, press Enter, and then type 

Questions or comments about the Web site? E-mail the Web-

master. 

6 Press Enter, display the Font Size drop-down list in the Formatting 

toolbar, choose 1 (8 pt), and then type Copyright [the current 

year] – [your name or organization’s name]. 

7 Press Enter, and click Save in the Standard toolbar. 

You’re now ready to link the navigation bar’s text and add a Mail To link to the 

E-mail the Webmaster text: 

8 Select Home in the text-based navigation bar, right-click the se-

lected text, and click Hyperlink. 

9 In the Insert Hyperlink dialog box, ensure that the Look In drop-

down list shows sky, click in the Address text box, type index.htm 

(be sure to delete the http:// if it displays), as shown in Figure 7-19, 

and then click OK or press Enter. 

 
Figure 7-19. 

The Insert Hyperlink dialog box enables you to easily configure hyper-

links in FrontPage. 

You can also press Ctrl+K to 

open the Insert Hyperlink di-

alog box. 

If you want to add a ScreenTip 

to your text hyperlinks, click 

the ScreenTip button in the 

Insert Hyperlink dialog box. 
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10 Repeat steps 8 and 9 using the following parameters: 

 

Select and Right-Click Enter in the Address 

Text Box 

About Us aboutus.htm 

Contact Us contact.htm 

Meetings meetings.htm 

Sky Guide skyguide.htm 

Photo Gallery gallery.htm 

Links links.htm 

11 Select the E-mail The Webmaster text, right-click the selected text, 

and click Hyperlink to open the Insert Hyperlink dialog box. 

12 In the Insert Hyperlink dialog box, click the E-Mail Address button 

in the Link To section, as shown in Figure 7-20. 

 
Figure 7-20. 

You can create hyperlinks that automatically open a preaddressed message 

form. 

13 Enter your e-mail address in the E-mail Address text box, enter 

The Astronomy Club in the Subject text box (see Figure 7-20), click 

OK, and then save your work. The lower portion of your subpage 

template should appear as shown in Figure 7-21, which shows the 

Preview view (remember, if you didn’t modify your hover button’s 

applet code, you need to choose Preview In Browser on the File 

menu to properly preview your subpage Web page). Note also that 

the copyright date and organization name will depend on the in-

formation you supply. 



Lesson 7 Creating Web Sites with FrontPage 7.25 

 
Figure 7-21. 

The subpage’s footer information provides visitors with text links, Webmaster 

access, and copyright information. 

14 Close subpage.htm. 

You now have a subpage template ready for use. 
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Now you’re going to use subpage.htm to create a couple subpages for the astron-

omy club’s Web. The site requires six main subpages: 

■ aboutus.htm 

■ contact.htm 

■ meetings.htm 

■ skyguide.htm 

■ gallery.htm 

■ links.htm 

In this section you’ll complete the contact.htm and skyguide.htm as well as a 

subpage (mars.htm) of the skyguide.htm page. Although we don’t walk you 

through the creation of all the subpages, the images you copied into 

C:\sky\images from the Lesson07 folder under the Web Design Fundamentals 

Practice folder include title bar text graphics so that you can complete all the 

subpages on your own if you want to. We chose to show you how to complete 

mars.htm, skyguide.htm, and contact.htm because creating each of those pages 

includes information on how to add particular functionality to your Web pages, 

as follows: 
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■ mars.htm Shows you how to use the thumbnail feature in Front-

Page as well as copy text from a Word document and modify cas-

cading style sheets. Furthermore, this page links to the Sky Guide 

page (skyguide.htm). 

■ skyguide.htm Teaches you how to create an image map in Front-

Page. 

■ contact.htm Provides a quick overview of how to create a working 

form in FrontPage. 

After you create the three subpages described in this project, you’ll be fully pre-

pared to experiment and complete the remaining subpages on your own. 
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Preparing to create subpages is straightforward now that you’ve laid such a solid 

groundwork by creating the subpage.htm template. To use the template, you 

simply save copies of the subpage.htm file with different names and title text, as 

follows: 

1 Open C:\sky\subpage.htm in FrontPage. 

2 Click Save As on the File menu to open the Save As dialog box 

and ensure that the Save In text box displays the C:\sky folder. 

3 In the Page Title section, click the Change Title button, type The 

Astronomy Club: About Us in the Set Page Title dialog box, and 

click OK. 
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You can change a Web page’s title text at any time. To do so, click Proper-

ties on the File menu, change the Title text, and then click OK. You added 

title text for each page as you created the pages in the preceding section. 

4 In the Filename text box, type aboutus.htm, and click Save. No-

tice that the Web page’s tab changes (below the toolbars) to reflect 

the new name of the current document. 

5 Without closing the current document (which is aboutus.htm at this 

point), repeat steps 2 through 4 using the filenames and title text 

shown in the table on the following page: 
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Save As Filename Page Title Text 

contact.htm The Astronomy 

Club: Contact Us 

meetings.htm The Astronomy 

Club: Meetings 

skyguide.htm The Astronomy 

Club: Sky Guide 

gallery.htm The Astronomy 

Club: Gallery 

links.htm  

mars.htm  

#�
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You need to name the subpages in the same way they were referenced 

when you linked the navigation buttons and hypertext links. For example, 

the About Us subpage needs to be saved with the name aboutus.htm. Do 

not alter the file names at this point. 

6 Close FrontPage, open your C:\sky folder, and verify that the folder 

contains a file for each Web page in your Web site. 

7 After you verify the list of newly created files, close your C:\sky 

folder. 
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After you create new files based on the subpage.htm file, you can open the new 

documents in FrontPage and customize the files’ contents. The first subpage 

you’ll create is an informational page about the planet Mars. In this section 

you’ll add text and a title bar graphic: 

1 Open FrontPage, click the Open button on the toolbar, display the 

contents of C:\sky in the Open dialog box, and double-click the 

mars.htm file. 

2 Click to the right of the title bar graphic, press Shift+Enter, click 

Insert Picture From File on the Standard toolbar, display the con-

tents of C:\sky\images, and double-click t_skyguide.gif. The 

mars.htm page is a subpage of the Sky Guide, so it should display 

the Sky Guide subtitle bar. 

3 With your cursor still located at the end of the Sky Guide graphic, 

press your Delete key twice to bring the table closer to the 

t_skyguide.gif image. 

4 Right-click the t_skyguide.gif image, select Picture Properties, click 

the General tab, type Sky Guide in the Alternative Representa-

tions Text box, and click OK. 

Now you’ll add some text to the Web page’s table. 
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5 Open C:\sky, and then double-click mars.doc (not mars.htm) to 

open the Word document. 

6 Arrange your desktop so that you can see some portion of the 

Word document’s text as well as mars.htm in FrontPage, similar to 

the layout shown on the left in Figure 7-22. 

7 Click within the Word document, and press Ctrl+A to select the 

entire contents of the Word document. 
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You can type text directly into the table (as you’ll see later in this project), 

but we provided text for this page so that you wouldn’t have to retype the 

information. You can also copy and paste information into FrontPage, or 

you can use the File command on the Insert menu to import text from 

another file. 

8 Drag the selected text in the Word document into the large white 

portion of the table in mars.htm (which is technically the fourth cell 

in the first row of the table). The text should fill the table cell, as 

shown on the right in Figure 7-22. 

Figure 7-22. 

For this project you can drag text from a Word document into your Web page. 

Because you did not enter width or height limitations for the cell, the cell ex-

pands to accommodate the copied text. 

9 Save your Web page, and close the Word document. 
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To help format your Web pages’ contents, you can create external and embedded 

cascading style sheets from within FrontPage. An external style sheet means 

that formatting code is placed in a separate document that your Web page links 

to, while an embedded style sheet places formatting code within the current Web 

page’s source code. 

When you use style sheet settings, you define the style for a particular page ele-

ment—such as a heading 3 or bulleted list item—and then browsers (and Front-

Page) will automatically apply the style settings to all instances of the element. 

Lingo: A cascading style 

sheet contains code that de-

fines the appearance and 

formatting of a Web page or 

group of Web pages. 
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For instance, if you want all heading 3 type headings to display in blue, you only 

have to modify the style settings for the h3 element. After you save the modified 

settings, all heading 3s will appear blue. 

In this section you’ll use FrontPage to customize styles by defining an embedded 

style sheet. Therefore, the styles you define on the mars.htm page will only apply 

to the mars.htm page. To define embedded styles in FrontPage, follow these 

steps: 

1 Ensure that mars.htm displays in Normal view in FrontPage, and 

then click Style on the Format menu. 

2 In the Style dialog box, click the List drop-down arrow, and choose 

HTML tags. A list of HTML tags displays in the Styles list. 

First, you will specify to display all heading 3 elements in blue and 

12 point. 

3 In the Styles list, choose h3, as shown in Figure 7-23. 

 
Figure 7-23. 

You can define HTML styles by selecting the style you want to format from the 

list of HTML tags in the Style dialog box. 

4 Click Modify, click Format in the Modify Style text box, and click 

Font. 
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5 In the Font dialog box, click 12 pt in the Size list box, click the Col-

or drop-down arrow, click the blue color square, and click OK three 

times to close the open dialog boxes. 

Both the Description: and the Planetary Data: headings should now 

appear blue and in 12 point. Now, you’ll replace the standard black 

bullets in the bulleted list with custom bullets: 

6 Click Style on the Format menu, click HTML tags in the List box, 

select li in the Syles list, and click Modify. 

7 In the Modify Style dialog box, click Format, and click Numbering. 

8 In the Bullets And Numbering dialog box, click Browse, display the 

contents of the C:\sky\images folder in the Select Picture dialog 

box, and double-click bullet_star.gif.to complete the Bullets And 

Number dialog box. 

9 Click OK three times to close the open dialog boxes. The bulleted 

list on your page should display with star images in Normal view as 

shown in Figure 7-24, and your source code should now include 

embedded styles as shown in Figure 7-25 (with the orange color 

highlighting the formatting information you added in the preceding 

steps). 

10 Save mars.html and ensure that it displays in Normal view in prep-

aration for the next section. 

 
Figure 7-24. 

The newly defined styles colors heading 3s blue and displays the bulleted 

list with star bullets. 
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Figure 7-25. 

FrontPage automatically generates embedded style information. 
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Now that you’ve imported and formatted text in your Mars Web page, you’re 

ready to add an image. In this section you’ll insert a thumbnail image of Mars, 

which means viewers will be able to click a small image of Mars to view a larg-

er version of the picture. Providing a thumbnail image speeds your page’s down-

load time and provides viewers the option to download a larger version of the 

picture if they desire. To insert a thumbnail image in FrontPage, follow these 

steps: 

1 In FrontPage, click to the right of Our Solar System: Mars (the top 

line of the inserted text), click Insert Picture From File on the Stan-

dard toolbar, and double-click the mars.jpg image from the 

C:\sky\images folder. A very large picture of Mars takes over your 

view in FrontPage. 

2 Click Mars and then display the Pictures toolbar (if the toolbar 

doesn’t display automatically, choose Toolbars on the View menu, 

and then choose Pictures). Figure 7-26 shows the Mars picture 

along with the Pictures toolbar. 
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Figure 7-26. 

You can create a thumbnail image of Mars directly in FrontPage. 

3 With the picture of mars still selected, click the Auto Thumbnail 

button in the Pictures toolbar (it’s the third button from the left). A 

100-by-100-pixel version of Mars is created from the larger version 

of mars.jpg. The smaller graphic is automatically named 

mars_small.jpg. 

4 Right-click the thumbnail picture of Mars, choose Picture Proper-

ties, select the Appearance tab if necessary, and configure the 

properties as follows: 

Option Setting 

Alignment Right 

Border Thickness 0 

Horizontal Spacing 15 

Vertical Spacing 10 
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If you want your thumbnail to display larger than 100 x 100 pixels, you can 

select the Specify Size check box in the Picture Properties dialog box and 

change the size of the thumbnail image. 

5 Click OK, and then click in the text to deselect the graphic. 

6 Right-click anywhere on the table and choose Table Properties. 

The Table Properties dialog box opens. 
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7 In the Borders section, type 0 in the Size text box, and then click 

OK. 

8 Click Save, click Change Folder in the Save Embedded Files di-

alog box, double-click the images folder, click OK twice, and then 

click the Preview view tab (or choose Preview In Browser on the 

File menu). Your mars.htm page should now look similar to Figure 

7-27, and the small graphic is automatically linked to mars.jpg. 

 

Figure 7-27. 

If you click your thumbnail graphic while previewing your page, a large image 

of Mars should display. 

9 Close mars.htm. 
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The project image files supplied for this lesson include neptune.jpg and sa-

turn.jpg, which are pictures of Neptune and Saturn (respectively) that you can 

use if you’d like to create additional planet informational pages for extra prac-

tice. 

Congratulations! You’ve completed your first subpage for the astronomy club’s 

Web site. No reason to stop now—in the next section, you’ll learn how to add an 

image map. 
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In this section you’ll create an image map on the Sky Guide’s main subpage. 

You’ll create the image map from a picture of the solar system. You’ll format 

the solar system image so that when users click the picture of Mars, the mars.htm 

page you created in the preceding section will display. To accomplish this (it’s 

easier than it sounds), follow these steps: 

1 Open FrontPage, click the Folders icon in the Views Bar, and 

double-click the skyguide.htm file. 

2 Click to the right of the title bar graphic, press Shift+Enter, click 

Insert Picture From File on the Standard toolbar, and double-click 

t_skyguide.gif. 

To test the thumbnail link, click 

the Preview view tab and then 

click the thumbnail picture of 

Mars. Click the Normal view 

tab to return to working view. 
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3 With the cursor still located at the end of the Sky Guide graphic, 

press your Delete key twice to bring the table closer to the 

t_skyguide.gif image. 

4 Right-click the t_skyguide.gif image, select Picture Properties, click 

the General tab, type Sky Guide in the Alternative Representa-

tions Text box, and click OK. 

Now you’ll add some content to the Web page’s table. 

5 Click in the large table cell to the right of the Home button, and 

type This Month’s Featured Item: Our Solar System. 

6 Select the text, click the Center icon on the Formatting toolbar, and 

select Comic Sans (or Comic Sans MS) in the Font drop-down list. 

7 Click after the word System, and press Shift+Enter twice. 

8 Type Click a planet to go to the planet’s information page. 

Note: Only Mars is active at this time. 

9 Click in the blank area between the two text components you add-

ed in steps 5 and 8. 

10 On the Standard toolbar, click Insert Picture From File, navigate to 

the C:\sky\images folder if necessary, and double-click solarsys-

tem.gif. 

11 Right-click anywhere on the table, choose Table Properties, set the 

Border Size to 0 in the Table Properties dialog box, and click OK. 

12 Click Save on the toolbar. Then preview your Web page. Your 

page should appear similar to the Web page shown in Figure 7-28. 

 
Figure 7-28. 

You’ll use the solar system picture to create an image map. 
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13 Return to Normal view in FrontPage. 

14 Click the solar system image. The Pictures toolbar should open 

automatically. Notice the Rectangular Hotspot, Circular Hotspot, 

and Polygonal Hotspot tools located toward the right end of the 

Pictures toolbar. 

15 Click the Polygonal Hotspot tool, and then click multiple points 

around Mars and the Mars label in the solar system graphic to 

create a polygon, as shown in Figure 7-29. When you complete the 

polygon, the Insert Hyperlink dialog box opens automatically. If ne-

cessary, click Existing File Or Web Page in the Link To: section. 

 
Figure 7-29. 

The Hotspot tools on the Pictures toolbar enable you to draw clickable areas 

on images. 

16 In the Insert Hyperlink dialog box, double-click mars.htm (not 

mars.doc) in the C:\sky file list. 

17 Create shapes around the remaining planets (if desired) that point 

to future pages, such as mercury.htm, venus.htm, earth.htm, jupi-

ter.htm, saturn.htm, uranus.htm, neptune.htm, and pluto.htm. 

18 Save skyguide.htm, preview the page in Preview view, move your 

cursor over Mars (notice that the cursor changes to a hand), and 

click Mars to see whether your link works. 

19 Click the Normal view tab, close skyguide.htm, and close Front-

Page. 

You’re well on your way to creating the astronomy club’s Web site. The final 

subpage you’ll create is a form within the contact.htm page. 

������
�����	��

At this point you should be getting used to adding elements and configuring set-

tings in FrontPage. As we mentioned at the beginning of the lesson, the trick lies 

in knowing where to find tools and configuration menus. In this section you’ll 

create an online form. An online form enables users to enter information into text 

boxes. Then when users click the form’s Submit button, the results will be sent 

to your e-mail address. 

Lingo: A hotspot is a clickable 

area on an image that’s linked 

to another Web page or anoth-

er area on the current page. 

If you create a line that you 

don’t want to use, right-click to 

remove the existing lines, and 

start over. 

When you use Forms on your 

Web site, your server must 

support FrontPage Server 

Extensions and you must 

publish the form using the 

publishing tool in FrontPage. 
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Do not display your form in Preview view before you publish it to the Web. If 

you do, FrontPage 2002 adds code that inhibits your page from publishing prop-

erly. When you create a form, you must publish it to the Web and then preview 

the form in either FrontPage or your browser. 

Preparing the Contacts Page 

The first step to creating a form on the Contacts page is to prepare the page by 

adding a title bar and inserting title text, as described in the following steps: 

1 Open FrontPage, click Folder in the Views Bar, and double-click 

the contact.htm file. 

2 Click to the right of the title bar, press Shift+Enter, click Insert Pic-

ture From File, display the contents of C:\sky\images, and double-

click t_contact.gif. 

3 With the cursor still located at the end of the Contact Information 

graphic, press your Delete key twice to bring the table closer to the 

t_contact.gif image. 

4 Right-click the t_contact.gif image, select Picture Properties, click 

the General tab, type Contact Page in the Alternative Representa-

tions Text box, and click OK. 

Inserting a Form Area and Adding Labels 

Now that the Contacts page is ready for action, you’re set to create an online 

form. First you’ll insert the standard form box and then enter labels for the 

form’s text boxes, option buttons, and selection boxes: 

1 Click in the large table cell to the right of the Home button, point to 

Form on the Insert menu, and choose Form. An outlined area dis-

plays within the table that contains Submit and Reset buttons, as 

shown in Figure 7-30 on the following page. 
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Figure 7-30. 

The first step toward creating a form is to insert a form component, 

which automatically includes the Submit and Reset buttons. 

2 With the cursor positioned to the left of the Submit button, type 

Name:, and then press Shift+Enter. 

3 Type E-mail Address: and press Enter. 

4 Type Are you currently a club member? and press Enter. 

5 Type If so, how often do you attend our monthly meetings? 

and press Enter. 

6 Type Please let us know how you found our Web site (check 

all that apply):, press Shift+Enter, type I attended a meeting., 

press Shift+Enter, type I found it in a search engine., press 

Shift+Enter, type A friend told me., and then press Enter. 

7 Type Please enter comments or questions here:, press 

Shift+Enter, and then press Enter. Your form should appear similar 

to the form in progress shown in Figure 7-31. 
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Figure 7-31. 

The form in progress shows only the form’s text and basic buttons. 

Creating Form Fields 

You’re now ready to enter the form fields, the areas in which viewers select or 

enter text so that they can submit information. 

1 Click after Name:, press the spacebar, point to Form on the Insert 

menu, and choose Textbox. 

2 Click after E-mail Address:, press the spacebar, point to Form on 

the Insert menu, and choose Textbox. 

3 Click after Are You Currently A Club Member?, point to Form on 

the Insert menu, choose Option Button, type Yes, press your 

spacebar, point to Form on the Insert menu, choose Option Button, 

and then type No. 

4 Click after If So, How Often Do You Attend Our Monthly Meet-

ings?, press the spacebar, point to Form on the Insert menu, and 

choose Drop-Down Box. 

5 Click before I Attended A Meeting, point to Form on the Insert 

menu, choose Checkbox, and press your spacebar. 

6 Click before I Found It In A Search Engine, point to Form on the 

Insert menu, choose Checkbox, and press your spacebar. 

7 Click before A Friend Told Me, point to Form on the Insert menu, 

choose Checkbox, and press your spacebar. 

8 Click below Please Enter Comments Or Questions Here, point to 

Form on the Insert menu, and choose Text Area. 

We’ll format the form fields in 

a moment—so don’t be con-

cerned if the form fields don’t 

look quite right at this point. 
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9 Click Save. Your form should now display as shown in Figure 7-32. 

 

Figure 7-32. 

Your form should now include labels and unformatted form fields. 

Configuring Form Field Properties 

You now have the bulk of the form created. The next step is to configure the 

properties for each form field and specify the form’s overall properties. So get 

your right-click finger ready—you’re about to configure some property forms. 

1 Right-click the field next to Name and select Form Field Properties. 

2 In the Name field of the Text Box Properties dialog box, type 

Name, set the Width In Characters to 25 (as shown in Figure 7-33), 

enter 1 in the Tab Order text box, and then click OK. 
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Figure 7-33. 

You use the Text Box Properties dialog box to set the properties for a text 

box. 

3 Right-click the field next to E-mail Address, select Form Field 

Properties, type Email, set the Width In Characters to 30, enter 2 

in the Tab Order text box, and then click OK. 

4 Right-click the Yes button, choose Form Field Properties, type 

Member in the Group Name text box, type Yes in the Value text 

box, ensure that Selected is selected in the Initial State section, en-

ter 3 in the Tab Order text box, and click OK. 

5 Right-click the No button, choose Form Field Properties, type 

Member in the Group Name text box, type No in the Value text 

box, ensure that Not Selected is selected in the Initial State sec-

tion, and click OK. 
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Note that you don’t have to set a tab order for both the Yes and No options. Be-

cause the options are members of the same group, users can move to the group 

by pressing the Tab key. Then they can select an option by using the arrow keys. 

When they’re ready to move to the next section of the form, they can press Tab. 

6 Right-click the If So, How Often Do You Attend Our Monthly Meet-

ings? drop-down list box, and choose Form Field Properties. The 

Drop-Down Box Properties dialog box opens. 

7 Type Attendance in the Name text box, enter 4 in the Tab Order 

text box, and then click Add. The Add Choice dialog box opens. 

8 In the Add Choice dialog box, enter Every meeting, choose the 

Selected option in the Initial State section, and click OK. 

The Tab Order form field 

property specifies the order the 

cursor will move through a 

form if a user presses Tab to 

move from field to field. 
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9 Click Add, type Every other month, and click OK. 

10 Click Add, type Couple times a year, and click OK. 

11 Click Add, type Never, and click OK. Your Drop-Down Box Proper-

ties dialog box should look like the one shown in Figure 7-34. 

 
Figure 7-34. 

The completed Drop-Down Box Properties dialog box shows all the op-

tions and which option will be selected by default. 

12 Click OK. 

13 Right-click the first check box, choose Form Field Properties, enter 

FoundWebSite in the Name text box, enter Attended a meeting 

in the Value text box, enter 5 in the Tab Order text box, and click 

OK. 

14 Right-click the second check box, choose Form Field Properties, 

enter FoundWebSite in the Name text box, enter Search engine 

in the Value text box, enter 6 in the Tab Order text box, and click 

OK. 

15 Right-click the third check box, choose Form Field Properties, en-

ter FoundWebSite in the Name text box, enter Friend in the Value 

text box, enter 7 in the Tab Order text box, and click OK. 

16 Right-click the scrolling text box, choose Form Field Properties, 

type Comments in the Name text box, enter 40 in the Width In 

Characters text box, enter 8 in the Tab Order text box, enter 3 in 

the Number Of Lines text box, and click OK. 
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17 Right-click the Submit button, choose Form Field Properties, enter 

Submit in the Name text box, enter 9 in the Tab Order text box, 

and click OK. 

18 Right-click the Reset button, choose Form Field Properties, enter 

Reset in the Name text box, enter Clear Form in the Value/ Label 

text box, enter 10 in the Tab Order text box, and click OK. 

19 Click the Back arrow once and press your spacebar to insert a 

space between the Submit and Clear Form buttons. 

20 Click before the Name: label at the top of the form, and press 

Shift+Enter. Then save your work without previewing the form (re-

member, in order for your form to work properly, you need to pub-

lish your form to the Web before you preview the form). 
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Generally, you should supply a name for every form field. Field names help iden-

tify information after it’s submitted to you as well as enable browsers to diffe-

rentiate like elements. You can configure your form to display each field’s name 

along with the submitted data. This setup will help you to quickly see what in-

formation was submitted in response to which form field entries. For example, 

here’s what a filled-in online form and confirmation page might look like: 

 

Next, you would receive an e-mail message containing the submitted information 

similar to the following message: 
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The images displayed here show how the form you’re creating in this project will 

display after you publish the contact form to a Web server. 

Completing the Contacts Page 

To complete the Contacts page, you need to hide the table’s borders and set the 

form’s properties. 

1 Right-click anywhere on the table, choose Table Properties, enter 0 

in the Size text box in the Borders area, and click OK. 

2 Right-click the form, and choose Form Properties. The Form Prop-

erties dialog box opens. 

3 In the Form Properties dialog box, ensure that the Send To option 

is selected, enter your own e-mail address in the E-mail Address 

text box, and enter Astronomy Contact Form in the Form Name 

text box. 

4 In the Form Properties dialog box, click Options, click the E-mail 

Results tab, ensure that the Include Field Names check box is se-

lected, and enter Astronomy Contact Information in the Subject 

Line text box. Selecting the Include Field Names option specifies 

that the field names should accompany the submitted information, 

and the subject line text will appear in e-mail messages you re-

ceive after users click the Submit button. 

5 Click the Confirmation Page tab, type thankyou.htm in the URL 

Of Confirmation Page text box, click OK twice, and then click No. 

6 Save and close contact.htm, and then close FrontPage. 

That’s it for your subpage experimentation for this project. You’ve worked 

through a number of FrontPage features that you should be able to use when you 

create your own Web site. But before we wrap up this project, we need to create 

the astronomy club’s home page. 

To view a published version of 

the contacts page, visit 

www.creationguide.com/sky/c

ontact.htm. 
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Last but not least, you’re ready to create the home page. Creating this page 

might seem a little tricky at moments, and we’ll readily admit that it’s probably 

the most advanced procedure we describe in this course. However challenging, 

though, we want to give you an inkling of where you can go from here if we’ve 

inspired you to continue designing Web sites. (And we hope you do!) Further-

more, we thought you might be interested in seeing how tables and graphics are 

sometimes used to create advanced page layout designs. Anyway, let’s start by 

setting up the home page’s framework. 
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To begin, follow these steps: 

1 Open FrontPage, open C:\sky\subpage.htm, choose Save As on 

the File menu, click the Change Title button, enter Astronomy 

Club’s Official Web Site in the Set Page Title dialog box, click 

OK, enter index.htm in the File Name text box, and click Save. 

2 Right-click a blank area of the page, click Page Properties, click 

the Background tab, click the Text color box in the Colors section, 

choose White, and click OK. 

3 Place your cursor before the Home link in the text-based naviga-

tion bar, drag to select everything above the text-based navigation 

bar (including the title bar and logo graphic), right-click the selected 

elements, and click Cut. 

4 Press Enter, and then press the Up arrow button (or click in the 

space above the text-based navigation bar). 

5 Click Insert Picture From File, display the contents of 

C:\sky\images if necessary, and double-click titlebar-home.gif and 

press Enter. 

6 Click Web Component on the Standard toolbar, choose Dynamic 

Effects, and double-click Marquee. The Marquee Properties dialog 

box opens. 

7 In the Marquee Properties dialog box, type Our Next Meeting is 

February 21. Reserve your space today! in the Text text box—

this is the message that will scroll across the page. 

8 Choose the Slide option in the Behavior section, clear the Conti-

nuously check box in the Repeat section, and enter 1 in the Repeat 

text box, as shown in Figure 7-35. 
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Figure 7-35. 

Among other properties, you can specify whether marquee text scrolls 

continuously or scrolls a predetermined number of times. 

9 Click the Style button, click Format, click Font, choose Comic Sans 

(or Comic Sans MS) in the font list box, choose White in the Color 

box, and click OK three times to close all open dialog boxes. 

10 Press the Right arrow to deselect the marquee component, press 

Enter, click the Table button in the toolbar, and create a 1-row, 

5-column table. Your index.htm page should look similar to the 

page shown in Figure 7-36. 

 
Figure 7-36. 

The astronomy club’s home page is based on a custom table. 
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11 Right-click the table, choose Table Properties, click the Alignment 

drop-down list, select Center, ensure the Specify Width check box 

is selected, enter 580 in the Specify Width text box, choose the In 

Pixels option, ensure that Cell Padding and Cell Spacing are set to 

0, and click OK. 

12 Select all five table cells, right-click the selected cells, choose Cell 

Properties, set Vertical Alignment to Top, and then click OK. 

13 Right-click the titlebar-home.gif graphic, choose Picture Properties, 

click the General tab, type Welcome to the Astronomy Club Web 

Site in the Alternative Representations Text box, and click OK. 

14 Click Save. 
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You’re now going to insert pieces of an image that has been cut to fit into the 

table. The image, before we chopped it into pieces, is shown in Figure 7-37. The 

reason we divided the image into separate graphics is that we wanted to use Dy-

namic HTML (DHTML) to create a glowing rollover effect whenever users 

place their cursor over a hyperlinked area. If we hadn’t wanted to show the rol-

lover effect (and demonstrate how you can chop up and reassemble pictures 

when necessary), we could’ve created an image map similar to the solar system 

image map you created on the Sky Guide page earlier in this lesson. 

 
Figure 7-37. 

The original Big Dipper image shown here was chopped into pieces for this 

project. 
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DHTML (Dynamic HTML) is a technology that provides Web pages with the 

capability to change and update automatically in response to a user’s actions, 

such as displaying a graphic or additional information in response to a user’s 

mouse movement. 

1 In index.htm, click in cell 1, click Insert Picture From File on the 

Standard toolbar, display the contents of C:\sky\images, and 

double-click bigdip1.gif. 

2 Click in cell 2 and insert b_aboutus.gif. 
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3 Click in cell 3, insert bigdip2.gif (a transparent graphic that will help 

to align the other graphics), press Shift+Enter, insert b_contact.gif, 

press Shift+Enter, insert b_meetings.gif, press Shift+Enter, and in-

sert b_skyguide.gif. 

4 Click in cell 4 and insert bigdip3.gif. 

5 Click in cell 5, and insert bigdip4.gif (another transparent image), 

press Shift+Enter, insert b_gallery.gif, press Shift+Enter, insert 

bigdip5.gif, press Shift+Enter, and insert b_links.gif. Your in-

dex.htm page should display as shown in Figure 7-38. 

 
Figure 7-38. 

After piecing Big Dipper back into shape, you’re ready to link the Big 

Dipper pieces to your subpages. 
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The next step is to link each image that contains a button name in the Big Dipper 

graphic to the appropriate subpage: 

1 Right-click the About Us text, choose Hyperlink, ensure that the sky 

folder appears in the Look In text box, type aboutus.htm in the 

Address text box (or select the aboutus.htm file in the file list), and 

click OK. 

2 Link the remaining graphics as follows: 

Graphic Link To 

Contact Us contact.htm 

Meetings meetings.htm 

Sky Guide skyguide.htm 

Photo Gallery gallery.htm 

Astronomy Links links.htm 

To speed up the hyperlinking 

process, you can double-click 

file names in the file list in the 

Insert Hyperlink dialog box 

instead of typing each file 

name into the Address text 

box. 
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3 Click Save. 
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Next you’ll add the rollover effect to each hyperlinked area in the table by using 

the FrontPage DHTML toolbar: 

1 Select the About Us button and choose Dynamic HTML Effects on 

the Format menu. The DHTML Effects toolbar displays. You’ll con-

figure the toolbar to display as shown in Figure 7-39. 

 
Figure 7-39. 

The DHTML Effects toolbar assists you in applying dynamic effects to 

your Web pages. 

2 In the On drop-down list, choose Mouse Over. 

3 In the Apply drop-down list, choose Swap Picture, click the Choose 

Settings drop-down list, select Choose Picture, and then double-

click b_aboutus2.gif in the C:\sky\images folder. 

4 Repeat steps 1 through 3 for each linked area, linking the second-

ary graphics as follows: 

Link  Picture File 

Contact Us b_contact2.gif 

Meetings  b_meetings2.gif 

Sky Guide  b_skyguide2.gif 

Photo Gallery b_gallery2.gif 

Astronomy Links b_links2.gif 

5 Close the DHTML Effects toolbar. 

6 Right-click the table, choose Table Properties, enter 0 in the Size 

text box in the Borders section, click Apply, and then click OK. 

7 Click Save and then preview your work. 

8 Click the Normal view tab to return to your working area. 
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Finally, to complete the home page, you’ll insert counter and last-modified date 

elements. To insert a counter, follow these steps: 

1 On index.htm, click after the Links hyperlink in the text navigation 

bar, press Enter, point to Web Component on the Insert menu, and 

choose Hit Counter in the Component Type list. Click Finish and 

the Hit Counter Properties dialog box displays. 

2 In the Choose A Counter Style list, select the green digital number 

style (it’s the last style on the list), then choose the Fixed Number 

Counter elements won’t dis-

play until you publish your 

FrontPage Web. 
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Of Digits check box, accept the default setting of 5 digits, and click 

OK. 

3 Press Enter, choose Date And Time on the Insert menu, and click 

OK on the Date And Time dialog box. The date will automatically 

update each time you edit the page. 

4 Save index.htm, and then click Preview. Your page should look 

similar to the page shown in Figure 7-40. After you publish your sky 

Web site, your home page will display the counter instead of 

placeholder text. 

 
Figure 7-40. 

The completed index.htm file is shown here in Preview mode. 

You’ve completed the home page and most of the subpages for the astronomy 

club’s Web site. Great work! You should now understand some of the cool ca-

pabilities of FrontPage. We hope this newfound knowledge will help you as you 

design and create your own Web sites. 

As far as the astronomy club’s site, the only remaining step is to publish the 

C:\sky Web by using the Publish feature in FrontPage. Be sure to read the fol-

lowing section before you upload your astronomy club Web site to your server 

space. 
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When you create Webs in FrontPage, your best bet is to upload the pages using 

the FrontPage Publish Web feature, especially if you’ve inserted items that rely 

on FrontPage Server Extensions (such as forms and counters). To publish your 

site, select the Publish Web option on the File menu. You should have your serv-

er space and address already lined up. Furthermore, you should have ensured 

To see a live version of the 

astronomy club Web site 

created in this project, visit 

www.creationguide.com/sky. 
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with your hosting service that FrontPage Server Extensions are supported. For 

more information about publishing FrontPage Webs and using FrontPage Server 

Extensions, contact your Internet service provider (ISP) and refer to the help 

files in FrontPage. 
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Here are a couple FrontPage references we’ve found helpful: 

■ Buyens, Jim. Microsoft FrontPage Version 2002 Inside Out. Red-

mond, WA: Microsoft Press, 2001. This book is a complete Front-

Page documentation source. 

■ www.microsoft.com/frontpage is the definitive online resource for 

FrontPage. 
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■ FrontPage is a full-featured HTML editing program. 

■ You can use FrontPage to easily create advanced Web page fea-

tures such as button rollover effects, image maps, thumbnails, 

forms, counters, and other Web page components. 

■ The FrontPage interface enables you to display your Web pages in 

Normal (working) view, HTML view, and Preview view. 

■ Learning FrontPage opens doors to using other full-service HTML 

editors because it exemplifies the types of capabilities HTML edi-

tors can provide. 

■ Before you create your Web pages using FrontPage, you should 

ensure that your Web hosting service supports FrontPage Server 

Extensions. (These days, most servers support extensions to some 

degree.) 

■ Before you start creating Web pages in FrontPage, you should set 

up a Web, which provides special formatting to a selected folder. 

■ You can simplify the process of building a Web site by creating a 

standard template that you can save as subpages. 

■ The key to creating Webs in FrontPage is keeping your files orga-

nized, knowing where to find FrontPage tools and menu options, 

and experimenting with various settings. 

■ For best results, upload FrontPage files using the Publish Web fea-

ture. 

 


